Дорогу осилит идущий (eking_go) wrote in ru_gentoo,
Дорогу осилит идущий
eking_go
ru_gentoo

X + Asus eeepc 701

Гуглил, но ничего не нагуглил :(
Запустить никак не получается. Куда рыть? Как запустить иксы в режиме максимального количества сообщений в лог - дебаг или что-то подобное...

X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.36-gentoo-r5 i686 Gentoo
...
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
Sandybridge, Sandybridge
(--) using VT number 7
(EE) No devices detected.
Fatal server error:
no screens found


Логи и конфиги:

lspci -k | grep agp
Kernel driver in use: agpgart-intel
Kernel modules: intel-agp

dmesg:agpgart-intel 0000:00:00.0: Intel 915GM Chipset
agpgart-intel 0000:00:00.0: detected 7932K stolen memory
agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xd0000000
...
uvesafb: Intel Corporation, Intel(r)915GM/910ML/915MS Graphics Controller, Hardware Version 0.0, OEM: Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS, VBE v3.0
uvesafb: VBIOS/hardware doesn't support DDC transfers
uvesafb: no monitor limits have been set, default refresh rate will be used
uvesafb: scrolling: redraw
Console: switching to colour frame buffer device 80x30
uvesafb: framebuffer at 0xd0000000, mapped to 0xf9780000, using 2400k, total 7872k
fb0: VESA VGA frame buffer device
...

rc-status
Runlevel: default
acpid [ started ]
dbus [ started ]
gpm [ started ]
hald [ started ]
iptables [ started ]
local [ started ]
net.eth0 [ started ]
netmount [ started ]
rsyslog [ started ]
sshd [ started ]
udev-postmount [ started ]
vixie-cron [ started ]

/var/log/Xorg.0.log
[ 892.668]
X.Org X Server 1.9.4
Release Date: 2011-02-04
[ 892.674] X Protocol Version 11, Revision 0
[ 892.676] Build Operating System: Linux 2.6.36-gentoo-r5 i686 Gentoo
[ 892.678] Current Operating System: Linux eking-netbook 2.6.36-gentoo-r5 #1 SMP Thu Mar 17 14:19:46 EET 2011 i686
[ 892.682] Kernel command line: root=/dev/ram0 real_root=/dev/sda1
[ 892.684] Build Date: 13 March 2011 08:52:09PM
[ 892.686]
[ 892.688] Current version of pixman: 0.20.2
[ 892.690] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 892.694] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 892.700] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 3 21:16:14 2011
[ 892.703] (==) Using config file: "/etc/X11/xorg.conf"
[ 892.705] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 892.708] (==) ServerLayout "X.org Configured"
[ 892.708] (**) |-->Screen "Screen0" (0)
[ 892.708] (**) | |-->Monitor "Monitor0"
[ 892.708] (**) | |-->Device "Card0"
[ 892.708] (**) |-->Input Device "Mouse0"
[ 892.708] (**) |-->Input Device "Keyboard0"
[ 892.709] (==) Automatically adding devices
[ 892.709] (==) Automatically enabling devices
[ 892.709] (**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/,
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/OTF/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi/,
/usr/share/fonts/75dpi/
[ 892.709] (**) ModulePath set to "/usr/lib/xorg/modules"
[ 892.709] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 892.709] (WW) Disabling Mouse0
[ 892.709] (WW) Disabling Keyboard0
[ 892.709] (II) Loader magic: 0xb774ad80
[ 892.709] (II) Module ABI versions:
[ 892.710] X.Org ANSI C Emulation: 0.4
[ 892.710] X.Org Video Driver: 8.0
[ 892.710] X.Org XInput driver : 11.0
[ 892.710] X.Org Server Extension : 4.0
[ 892.712] (--) PCI:*(0:0:2:0) 8086:2592:1043:82d9 rev 4, Mem @ 0xf7f00000/524288, 0xd0000000/268435456, 0xf7ec0000/262144, I/O @ 0x0000ec00/8
[ 892.712] (--) PCI: (0:0:2:1) 8086:2792:1043:82d9 rev 4, Mem @ 0xf7f80000/524288
[ 892.714] (II) Open ACPI successful (/var/run/acpid.socket)
[ 892.714] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[ 892.714] (II) LoadModule: "glx"
[ 892.715] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 892.716] (II) Module glx: vendor="X.Org Foundation"
[ 892.716] compiled for 1.9.4, module version = 1.0.0
[ 892.716] ABI class: X.Org Server Extension, version 4.0
[ 892.716] (==) AIGLX enabled
[ 892.716] (II) Loading extension GLX
[ 892.716] (II) LoadModule: "extmod"
[ 892.717] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[ 892.717] (II) Module extmod: vendor="X.Org Foundation"
[ 892.717] compiled for 1.9.4, module version = 1.0.0
[ 892.717] Module class: X.Org Server Extension
[ 892.717] ABI class: X.Org Server Extension, version 4.0
[ 892.717] (II) Loading extension MIT-SCREEN-SAVER
[ 892.718] (II) Loading extension XFree86-VidModeExtension
[ 892.718] (II) Loading extension XFree86-DGA
[ 892.718] (II) Loading extension DPMS
[ 892.718] (II) Loading extension XVideo
[ 892.718] (II) Loading extension XVideo-MotionCompensation
[ 892.718] (II) Loading extension X-Resource
[ 892.718] (II) LoadModule: "record"
[ 892.719] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[ 892.719] (II) Module record: vendor="X.Org Foundation"
[ 892.719] compiled for 1.9.4, module version = 1.13.0
[ 892.719] Module class: X.Org Server Extension
[ 892.719] ABI class: X.Org Server Extension, version 4.0
[ 892.719] (II) Loading extension RECORD
[ 892.719] (II) LoadModule: "dri2"
[ 892.720] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[ 892.721] (II) Module dri2: vendor="X.Org Foundation"
[ 892.721] compiled for 1.9.4, module version = 1.2.0
[ 892.721] ABI class: X.Org Server Extension, version 4.0
[ 892.721] (II) Loading extension DRI2
[ 892.721] (II) LoadModule: "dbe"
[ 892.722] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[ 892.722] (II) Module dbe: vendor="X.Org Foundation"
[ 892.722] compiled for 1.9.4, module version = 1.0.0
[ 892.722] Module class: X.Org Server Extension
[ 892.722] ABI class: X.Org Server Extension, version 4.0
[ 892.722] (II) Loading extension DOUBLE-BUFFER
[ 892.722] (II) LoadModule: "dri"
[ 892.723] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[ 892.723] (II) Module dri: vendor="X.Org Foundation"
[ 892.723] compiled for 1.9.4, module version = 1.0.0
[ 892.723] ABI class: X.Org Server Extension, version 4.0
[ 892.723] (II) Loading extension XFree86-DRI
[ 892.723] (II) LoadModule: "intel"
[ 892.724] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 892.725] (II) Module intel: vendor="X.Org Foundation"
[ 892.725] compiled for 1.9.4, module version = 2.14.0
[ 892.725] Module class: X.Org Video Driver
[ 892.725] ABI class: X.Org Video Driver, version 8.0
[ 892.725] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
Sandybridge, Sandybridge
[ 892.727] (--) using VT number 7

[ 892.739] (EE) No devices detected.
[ 892.739]
Fatal server error:
[ 892.739] no screens found
[ 892.739]
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 892.739] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 892.739]

Xorg -configure

X.Org X Server 1.9.4
Release Date: 2011-02-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.36-gentoo-r5 i686 Gentoo
Current Operating System: Linux eking-netbook 2.6.36-gentoo-r5 #1 SMP Thu Mar 17 14:19:46 EET 2011 i686
Kernel command line: root=/dev/ram0 real_root=/dev/sda1
Build Date: 13 March 2011 08:52:09PM

Current version of pixman: 0.20.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 4 18:13:40 2011
List of video drivers:
intel
vesa
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.


Что не так? Куда рыть? Все, что советовали на сайте gentoo - пробовал. :(

  • Post a new comment

    Error

    default userpic

    Your IP address will be recorded 

  • 10 comments