Mike Potanin (potan) wrote in ru_gentoo,
Mike Potanin
potan
ru_gentoo

ffmpeg и libav

Накопились проблемы, пытаюсь разгрести.
Запускаю emerge @preserved-rebuild, получаю ошибку:

[ebuild   R    ] media-video/libav-9999  USE="-theora* -vaapi* -vdpau*" 
[ebuild  N     ] media-video/ffmpeg-0.10.5  USE="3dnow 3dnowext X aac alsa amr avx bzip2 cpudetection debug dirac doc encode faac frei0r gsm hardcoded-tables ieee1394 jack jpeg2k mmx mmxext mp3 network oss pic rtmp schroedinger sdl speex ssse3 static-libs test theora threads truetype v4l vaapi vorbis vpx x264 xvid zlib -aacplus (-altivec) -bindist -cdio (-celt) -gnutls -libass -libv4l -modplug (-neon) -openal -openssl -pulseaudio -vdpau (-vis)" FFTOOLS="aviocat cws2fws ffeval graph2dot ismindex pktdumper qt-faststart trasher" 
[ebuild     U  ] media-video/vlc-9999 [1.1.8] USE="avcodec%* avformat%* bluray%* dvbpsi%* egl%* encode%* growl%* libtar%* linsys%* omxil%* postproc%* sid%* switcher%* swscale%* (-audioqueue) (-direct2d) (-directx) (-dshow) (-dxva2) (-ios-vout) -libsamplerate% (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) (-media-library) (-neon) (-waveout) (-wingdi)" 
[ebuild     U  ] media-libs/libdlna-0.2.4 [0.2.3]
[blocks B      ] media-video/ffmpeg ("media-video/ffmpeg" is blocking media-video/libav-9999)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/ffmpeg и все, что от него явно зависило я удалил и пересобрал с media-video/libav. Непонятно, почему он пытается установиться?

PS Еще ни как не удается наставить работать OpenGL на Radeon HD 3450. Это вообще реально, или я зря размечтался?
  • Post a new comment

    Error

    default userpic

    Your IP address will be recorded 

  • 1 comment